summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD46
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3267942655ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Wed Jun 14 16:12:28 UTC 2017
+pkgbase = xo-git
+ pkgdesc = Command line utility that composes regular expression matches.
+ pkgver = r90.0f7f076
+ pkgrel = 1
+ url = https://github.com/ezekg/xo
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = go
+ conflicts = xo
+
+pkgname = xo-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..162262c58097
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=xo-git
+pkgver=r90.0f7f076
+pkgrel=1
+epoch=
+pkgdesc="Command line utility that composes regular expression matches. "
+arch=('i686' 'x86_64')
+url="https://github.com/ezekg/xo"
+license=('MIT')
+categories=()
+groups=()
+depends=('')
+makedepends=('git' 'go')
+optdepends=()
+checkdepends=()
+provides=()
+conflicts=('xo')
+replaces=()
+backup=()
+options=()
+changelog=
+install=
+noextract=()
+_gourl=github.com/ezekg/xo
+
+pkgver() {
+ GOPATH="$srcdir" go get -d ${_gourl}
+ cd "$srcdir/src/${_gourl}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ GOPATH="$srcdir" go get -fix -v ${_gourl}
+}
+
+#check() {
+# GOPATH="$srcdir" go test -v -x ${_gourl}
+#}
+
+package() {
+ cd "$srcdir"
+ install -Dm755 bin/xo "$pkgdir/usr/bin/xo"
+ install -Dm644 src/${_gourl}/README.md $pkgdir/usr/share/doc/${pkgname%-*}/README.md
+ install -Dm644 src/${_gourl}/LICENSE $pkgdir/usr/share/licenses/${pkgname%-*}/LICENSE
+}
+