summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3bdcebb59e10..0efec29c7b94 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,7 +9,7 @@ pkgbase = xournalpp-git
license = GPL2
makedepends = git
makedepends = cmake
- makedepends = gettext
+ makedepends = cppunit
depends = texlive-bin
depends = gtk3
depends = glib2
@@ -17,8 +17,8 @@ pkgbase = xournalpp-git
depends = libxml2
depends = portaudio
depends = libsndfile
- depends = lua
depends = libzip
+ optdepends = lua>=5.3: Enable Xournal++ Plugins
conflicts = xournalpp
source = xournalpp::git+https://github.com/xournalpp/xournalpp.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 9cfe2749be71..f0b0b4d3870b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,8 +11,9 @@ pkgdesc='Xournal++ is a handwriting Notetaking software with PDF annotation supp
arch=('i686' 'x86_64')
url="https://github.com/xournalpp/xournalpp"
license=('GPL2')
-makedepends=('git' 'cmake' 'gettext')
-depends=('texlive-bin' 'gtk3' 'glib2' 'poppler-glib' 'libxml2' 'portaudio' 'libsndfile' 'lua' 'libzip')
+makedepends=('git' 'cmake' 'cppunit')
+depends=('texlive-bin' 'gtk3' 'glib2' 'poppler-glib' 'libxml2' 'portaudio' 'libsndfile' 'libzip')
+optdepends=('lua>=5.3: Enable Xournal++ Plugins')
conflicts=('xournalpp')
install="xournalpp.install"
source=("${_pkgname}::git+https://github.com/xournalpp/xournalpp.git")
@@ -34,8 +35,15 @@ build() {
configdir="$(realpath --relative-to="$HOME" "$XDG_CONFIG_HOME")"
fi
cd "${srcdir}/${_pkgname}/build"
- cmake -DCMAKE_INSTALL_PREFIX="/usr/" -DDEV_CONFIG_DIR="$configdir/xournalpp" ..
- make
+
+ cmake -DCMAKE_INSTALL_PREFIX="/usr/" -DDEV_CONFIG_DIR="$configdir/xournalpp" -DENABLE_CPPUNIT=ON ..
+ cmake --build .
+}
+
+check() {
+ cd "${srcdir}/${_pkgname}/build"
+
+ cmake --build . --target test
}
package() {