summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ac08cc8f765
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = xpytile-git
+ pkgdesc = Tiling and simultaneous resizing of side-by-side windows (not only) for Xfce.
+ pkgver = r22.6c202df
+ pkgrel = 1
+ url = https://github.com/jaywilkas/xpytile/
+ arch = any
+ license = GPL3
+ depends = python
+ depends = python-xlib
+ depends = libnotify
+ source = xpytile-git::git+https://github.com/jaywilkas/xpytile/
+ sha256sums = SKIP
+
+pkgname = xpytile-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e20bd7b52102
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: tuxifreund <kaiser.barbarossa@yandex.com>
+pkgname=xpytile-git
+pkgver=r22.6c202df
+pkgrel=1
+pkgdesc="Tiling and simultaneous resizing of side-by-side windows (not only) for Xfce."
+arch=('any')
+url="https://github.com/jaywilkas/xpytile/"
+license=('GPL3')
+depends=('python' 'python-xlib' 'libnotify')
+source=("${pkgname}::git+https://github.com/jaywilkas/xpytile/")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "${pkgname}"
+ install -Dm755 "xpytile.py" "${pkgdir}/usr/bin/xpytile"
+ install -Dm644 "xpytilerc" "${pkgdir}/etc/xpytilerc"
+}