summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3e25e84ba6f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = xrandr-multihead-bottom-git
+ pkgdesc = Align a bunch of screens to the bottom edge left to right via a xrandr call.
+ pkgver = r2.ee61e56
+ pkgrel = 1
+ url = https://github.com/hrehfeld/xrandr-multihead-bottom
+ arch = x86_64
+ arch = i686
+ makedepends = git
+ depends = xorg-xrandr
+ provides = xrandr-multihead-bottom
+ conflicts = xrandr-multihead-bottom
+ source = git+https://github.com/hrehfeld/xrandr-multihead-bottom.git
+ md5sums = SKIP
+
+pkgname = xrandr-multihead-bottom-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cde0c6dedbd1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Hauke Rehfeld <aur.archlinux.org@haukerehfeld.de>
+pkgname=xrandr-multihead-bottom-git
+pkgver=r2.ee61e56
+pkgrel=1
+pkgdesc="Align a bunch of screens to the bottom edge left to right via a xrandr call."
+arch=('x86_64' 'i686')
+depends=('xorg-xrandr')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+url="https://github.com/hrehfeld/xrandr-multihead-bottom"
+source=("git+${url}.git")
+noextract=()
+md5sums=("SKIP")
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ # Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ git checkout master
+}
+
+package() {
+ install -Dm755 "$srcdir/${pkgname%-git}/xrandr-multihead-bottom" "$pkgdir/usr/bin/xrandr-multihead-bottom"
+}