summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
-rw-r--r--make.patch41
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b99f9dee97e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = xrootconsole
+ pkgdesc = display a file (or stdin) to a transparent window
+ pkgver = 0.6
+ pkgrel = 1
+ url = https://sourceforge.net/projects/xrootconsole
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = libx11
+ source = http://downloads.sourceforge.net/project/xrootconsole/xrootconsole/0.6/xrootconsole-0.6.tar.gz
+ source = make.patch
+ md5sums = c3570d420eb5ae9f98385bc48c636fc4
+ md5sums = 8b122de1813ba3ca94889739c5373692
+
+pkgname = xrootconsole
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f774fa373c49
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: koneu <koneu93 at googlemail dot com>
+
+pkgname="xrootconsole"
+pkgver="0.6"
+pkgrel=1
+pkgdesc="display a file (or stdin) to a transparent window"
+url="https://sourceforge.net/projects/xrootconsole"
+license=("GPL2")
+source=("http://downloads.sourceforge.net/project/xrootconsole/xrootconsole/${pkgver}/xrootconsole-${pkgver}.tar.gz" "make.patch")
+depends=("libx11")
+arch=("i686" "x86_64")
+md5sums=('c3570d420eb5ae9f98385bc48c636fc4'
+ '8b122de1813ba3ca94889739c5373692')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ patch -p1 < ${srcdir}/make.patch
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ PREFIX=${pkgdir}/usr make install
+}
diff --git a/make.patch b/make.patch
new file mode 100644
index 000000000000..d9ab1b1c9dca
--- /dev/null
+++ b/make.patch
@@ -0,0 +1,41 @@
+--- a/Makefile
++++ b/Makefile
+@@ -32,10 +32,11 @@
+ #
+ ###########################################################################
+
++PREFIX ?= /usr/local
+ EXEC = xrootconsole
+-BINDIR = /usr/local/bin
++BINDIR = $(PREFIX)/bin
+ MANFILE = xrootconsole.1
+-MANDIR = /usr/local/share/man/man1
++MANDIR = $(PREFIX)/share/man/man1
+
+ VERSION = $(shell tag=$$(echo '$$Name: RELEASE-0_6 $$' | sed -e 's/\$$//g' -e 's/Name://g'); \
+ if [ $$tag ]; \
+@@ -43,13 +44,12 @@ VERSION = $(shell tag=$$(echo '$$Name: RELEASE-0_6 $$' | sed -e 's/\$$//g' -e 's
+ else echo Bleeding Edge Version; \
+ fi;)
+
+-CC = gcc
+-CPPFLAGS =
++CC ?= gcc
+
+ # for production
+-CFLAGS = -O2 -DNDEBUG -Wall "-DXROOTCONSOLE_VERSION=\"$(VERSION)\"" \
++CFLAGS += -O2 -DNDEBUG -Wall "-DXROOTCONSOLE_VERSION=\"$(VERSION)\"" \
+ -I /usr/X11R6/include
+-LDFLAGS = -s
++LDFLAGS += -s
+
+ # for testing
+ #CFLAGS = -g -Wall "-DXROOTCONSOLE_VERSION=\"$(VERSION) (debug build)\"" \
+@@ -76,5 +76,7 @@ realclean:
+ rm -f $(EXEC) *.o core *~
+
+ install: $(EXEC)
++ mkdir -p $(BINDIR)
+ cp $(EXEC) $(BINDIR)
++ mkdir -p $(MANDIR)
+ cp $(MANFILE) $(MANDIR)