summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
-rw-r--r--configure.in.patch23
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3aa299148d1d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = xsvg
+ pkgdesc = A viewer of SVG files
+ pkgver = 0.2.1
+ pkgrel = 7
+ url = http://cairographics.org/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = libsvg-cairo
+ depends = libpng
+ depends = libxinerama
+ depends = libxrandr
+ source = http://cairographics.org/snapshots/xsvg-0.2.1.tar.gz
+ source = configure.in.patch
+ md5sums = f20409e87d9bff3c4d698d8c0e9e9f2b
+ md5sums = cae774a2a7b60ab4d4600415b8265314
+
+pkgname = xsvg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e39a2e1e98c4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Contributor: Nicolas Bigaouette <bigaouette@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=xsvg
+pkgver=0.2.1
+pkgrel=7
+pkgdesc="A viewer of SVG files"
+url="http://cairographics.org/"
+license=('custom')
+depends=('libsvg-cairo' 'libpng' 'libxinerama' 'libxrandr')
+arch=('i686' 'x86_64')
+source=("http://cairographics.org/snapshots/$pkgname-$pkgver.tar.gz" configure.in.patch)
+md5sums=('f20409e87d9bff3c4d698d8c0e9e9f2b'
+ 'cae774a2a7b60ab4d4600415b8265314')
+
+prepare() {
+ cd $srcdir/$pkgname-$pkgver
+ patch -p1 < $srcdir/configure.in.patch
+ mv configure.in configure.ac
+}
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ aclocal
+ CC=gcc LDFLAGS="-lXinerama -lXrender -lX11 -lXrandr " ./configure --prefix=/usr --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make prefix=${pkgdir}/usr mandir=$pkgdir/usr/share/man install
+ install -Dm644 COPYING ${pkgdir}/usr/share/licenses/$pkgname
+}
diff --git a/configure.in.patch b/configure.in.patch
new file mode 100644
index 000000000000..79a90bd5b66b
--- /dev/null
+++ b/configure.in.patch
@@ -0,0 +1,23 @@
+diff -Naur xsvg-0.2.1.orig/configure.in xsvg-0.2.1.new/configure.in
+--- xsvg-0.2.1.orig/configure.in 2013-10-03 15:28:26.124461920 +0200
++++ xsvg-0.2.1.new/configure.in 2013-10-03 15:45:08.651048072 +0200
+@@ -1,11 +1,6 @@
+-AC_INIT(src/xsvg.c)
+-
+-dnl ===========================================================================
+-
+-XSVG_VERSION=0.2.1
+-AC_SUBST(XSVG_VERSION)
+-
+ dnl ===========================================================================
+
+-AM_INIT_AUTOMAKE(xsvg, $XSVG_VERSION)
+-AM_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADERS([config.h])
++AC_INIT([xsvg], [0.2.1])
++AC_CONFIG_SRCDIR([src/xsvg.c])
++AM_INIT_AUTOMAKE
+
+
+ AM_MAINTAINER_MODE
+