summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD34
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c8463445e635
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = xtrans13
+ pkgdesc = X transport library
+ pkgver = 1.3.5
+ pkgrel = 2
+ url = https://xorg.freedesktop.org/
+ arch = any
+ license = custom
+ provides = xtrans=1.3.5-2
+ conflicts = xtrans
+ options = !emptydirs
+ source = https://xorg.freedesktop.org//releases/individual/lib/xtrans-1.3.5.tar.bz2
+ source = https://xorg.freedesktop.org//releases/individual/lib/xtrans-1.3.5.tar.bz2.sig
+ validpgpkeys = C383B778255613DFDB409D91DB221A6900000011
+ sha512sums = 049fb996313e8a1625b66e1645a5f56d8a26c5dd91afe5869269716fce05f6c97c84f8ce4a6df2057106b47982c8291cecc223bef241f694174434c981a7029b
+ sha512sums = SKIP
+
+pkgname = xtrans13
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c1516990a40c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+
+pkgname=xtrans13
+_pkgname=xtrans
+pkgver=1.3.5
+pkgrel=2
+pkgdesc="X transport library"
+arch=('any')
+license=('custom')
+url="https://xorg.freedesktop.org/"
+options=(!emptydirs)
+provides=("$_pkgname=$pkgver-$pkgrel")
+conflicts=("$_pkgname")
+source=(${url}/releases/individual/lib/${_pkgname}-${pkgver}.tar.bz2{,.sig})
+sha512sums=('049fb996313e8a1625b66e1645a5f56d8a26c5dd91afe5869269716fce05f6c97c84f8ce4a6df2057106b47982c8291cecc223bef241f694174434c981a7029b'
+ 'SKIP')
+validpgpkeys=('C383B778255613DFDB409D91DB221A6900000011') # "Keith Packard <keithp@keithp.com>"
+
+build() {
+ cd ${_pkgname}-${pkgver}
+ ./configure --prefix=/usr
+}
+
+package() {
+ cd ${_pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+
+ install -m755 -d "${pkgdir}/usr/lib"
+ mv "${pkgdir}/usr/share/pkgconfig" "${pkgdir}/usr/lib/pkgconfig"
+}