summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD42
2 files changed, 23 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c52a16991a3..8577d250e419 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = yadm
pkgdesc = Yet Another Dotfiles Manager
- pkgver = 1.05.r0.g05ed83e
+ pkgver = 1.12.0
pkgrel = 1
url = https://github.com/TheLocehiliosan/yadm
arch = any
- license = GPL
- makedepends = git
- provides = /bin/yadm
- source = yadm::git+https://github.com/TheLocehiliosan/yadm#branch=master
- md5sums = SKIP
+ license = GPL3
+ optdepends = gpg: encrypt/decrypt sensitive files
+ optdepends = python-envtpl: use templates with variables
+ provides = yadm
+ conflicts = yadm-git
+ source = yadm-1.12.0.tar.gz::https://github.com/TheLocehiliosan/yadm/archive/1.12.0.tar.gz
+ sha256sums = c3d612d01e2027d5f457e0f7d120bc67251b716c373d99fe70638bd86edf107f
pkgname = yadm
diff --git a/PKGBUILD b/PKGBUILD
index f2ea69f73102..9e35d675548f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,25 @@
-# Maintainer: Franek Madej <franek.madej@gmail.com>
+# Maintainer: Stefan Tatschner <stefan@rumpelsepp.org>
+# Contributor: Franek Madej <franek.madej@gmail.com>
+# Completion changes and optdepends by Artemis
+
pkgname=yadm
-pkgver=1.05.r0.g05ed83e
+pkgver=1.12.0
pkgrel=1
pkgdesc="Yet Another Dotfiles Manager"
arch=('any')
url="https://github.com/TheLocehiliosan/yadm"
-license=('GPL')
-groups=()
-depends=()
-makedepends=('git')
-optdepends=()
-provides=('/bin/yadm')
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
-source=("${pkgname}::git+https://github.com/TheLocehiliosan/yadm#branch=master")
-noextract=()
-md5sums=('SKIP')
-
-pkgver() {
- cd $pkgname
- git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
-build() {
- cd ${srcdir}/${_pkgname}
-}
+license=('GPL3')
+optdepends=('gpg: encrypt/decrypt sensitive files'
+ 'python-envtpl: use templates with variables')
+provides=('yadm')
+conflicts=('yadm-git')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/TheLocehiliosan/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('c3d612d01e2027d5f457e0f7d120bc67251b716c373d99fe70638bd86edf107f')
package() {
- cd $srcdir/$pkgname
+ cd $srcdir/$pkgname-$pkgver
install -D -m 755 yadm $pkgdir/usr/bin/yadm
install -D -m 644 yadm.1 $pkgdir/usr/share/man/man1/yadm.1
+ install -D -m 644 completion/yadm.bash_completion "${pkgdir}/usr/share/bash-completion/completions/yadm"
+ install -D -m 644 completion/yadm.zsh_completion "${pkgdir}/usr/share/zsh/site-functions/_yadm"
}