summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 4 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f2930d1ce3fb..779e54fb762a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yaics
pkgdesc = A simple GNU social client developed in Qt
- pkgver = 0.5.r29.g1358c1a
+ pkgver = 0.6
pkgrel = 1
url = https://gitlab.com/stigatle/yaics/
arch = i686
@@ -10,7 +10,7 @@ pkgbase = yaics
depends = aspell
depends = hicolor-icon-theme
conflicts = yaics-git
- source = yaics::git+https://gitlab.com/stigatle/yaics.git
+ source = yaics::git+https://gitlab.com/stigatle/yaics.git#commit=eb921d1415843f2a88c2a73d5f9278b0d978caf4
sha256sums = SKIP
pkgname = yaics
diff --git a/PKGBUILD b/PKGBUILD
index 19e742e6222f..9ab03fc115ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Icaro Perseo <icaroperseo[at]protonmail[dot]com>
pkgname=yaics
-pkgver=0.5.r29.g1358c1a
+pkgver=0.6
pkgrel=1
pkgdesc="A simple GNU social client developed in Qt"
arch=('i686' 'x86_64')
@@ -9,17 +9,9 @@ conflicts=('yaics-git')
url="https://gitlab.com/stigatle/yaics/"
license=('GPL')
depends=('qt5-base' 'aspell' 'hicolor-icon-theme')
-source=("${pkgname}::git+https://gitlab.com/stigatle/yaics.git")
+source=("${pkgname}::git+https://gitlab.com/stigatle/yaics.git#commit=eb921d1415843f2a88c2a73d5f9278b0d978caf4")
sha256sums=('SKIP')
-pkgver() {
- cd "${pkgname}"
- ( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
-}
-
build() {
cd "${pkgname}"
qmake yaics.pro