summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f5acae0aa64..2cd562abb246 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = yamagi-quake2-rogue-git
pkgdesc = Quake II - Mission Pack 2 ('Ground Zero') for yamagi-quake2 (development version)
- pkgver = 2.01.r0.gf749f68
+ pkgver = 2.08.r1.gab882a1
pkgrel = 1
- url = http://www.yamagi.org/quake2/
+ url = https://www.yamagi.org/quake2/
install = yamagi-quake2-rogue.install
arch = i686
arch = x86_64
@@ -20,4 +20,3 @@ pkgbase = yamagi-quake2-rogue-git
sha256sums = e7ee884b1e015743659cf668afa521976de64345872acf8e4c1e6932355c2959
pkgname = yamagi-quake2-rogue-git
-
diff --git a/PKGBUILD b/PKGBUILD
index f11768e4e850..db8c1382032d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
pkgname=yamagi-quake2-rogue-git
-pkgver=2.01.r0.gf749f68
+pkgver=2.08.r1.gab882a1
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="Quake II - Mission Pack 2 ('Ground Zero') for yamagi-quake2 (development version)"
-url="http://www.yamagi.org/quake2/"
+url="https://www.yamagi.org/quake2/"
license=('GPL' 'custom')
depends=('sh' 'yamagi-quake2')
provides=("${pkgname%-*}")
@@ -28,19 +28,21 @@ build() {
}
package() {
- cd ${pkgname%-*}
+ local pkg=${pkgname%-*}
- # game launcher
- install -Dm755 ../${pkgname%-*}.sh "$pkgdir"/usr/bin/${pkgname%-*}
+ cd $pkg
# game library
- install -Dm644 release/game.so "$pkgdir"/usr/share/yamagi-quake2/rogue/game.so
+ install -Dm644 -t "$pkgdir"/usr/lib/yamagi-quake2/rogue release/game.so
+
+ # game launcher
+ install -Dm755 ../$pkg.sh "$pkgdir"/usr/bin/$pkg
# doc
- install -Dm644 README "$pkgdir"/usr/share/doc/${pkgname%-*}/README
+ install -Dm644 -t "$pkgdir"/usr/share/doc/$pkg README
# desktop entry
- install -Dm644 ../${pkgname%-*}.desktop "$pkgdir"/usr/share/applications/${pkgname%-*}.desktop
+ install -Dm644 -t "$pkgdir"/usr/share/applications ../$pkg.desktop
# license
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE