summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19585f30c1e2..222d7645c94f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,9 +17,9 @@ pkgbase = yarc-launcher
depends = openssl
depends = pango
depends = webkit2gtk
- optdepends = hidapi: support for HID devices in-game
- optdepends = pulseaudio-alsa: audio support in-game
- optdepends = systemd-libs: libudev required in-game
+ optdepends = hidapi: support for HID devices (in-game)
+ optdepends = pulseaudio-alsa: audio support (in-game)
+ optdepends = systemd-libs: access to HID devices (in-game)
conflicts = yarc-launcher-bin
options = !lto
source = yarc-launcher-0.3.1.tar.gz::https://github.com/YARC-Official/YARC-Launcher/archive/refs/tags/v0.3.1.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 7a9bb9a910bd..35c069f0dd04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
pkgname=yarc-launcher
pkgver=0.3.1
pkgrel=2
-pkgdesc="The official launcher for YARG (a.k.a. Yet Another Launcher or YAL)"
+pkgdesc='The official launcher for YARG (a.k.a. Yet Another Launcher or YAL)'
arch=(x86_64)
url=https://github.com/YARC-Official/YARC-Launcher
-license=("custom: YARG License")
+license=('custom: YARG License')
depends=(
cairo
gdk-pixbuf2
@@ -19,9 +19,9 @@ depends=(
)
makedepends=(cargo nodejs npm)
optdepends=(
- "hidapi: support for HID devices in-game"
- "pulseaudio-alsa: audio support in-game"
- "systemd-libs: libudev required in-game"
+ 'hidapi: support for HID devices (in-game)'
+ 'pulseaudio-alsa: audio support (in-game)'
+ 'systemd-libs: access to HID devices (in-game)'
)
conflicts=($pkgname-bin)
options=(!lto)
@@ -51,7 +51,7 @@ build() {
package() {
cd YARC-Launcher-$pkgver/
- # 69-hid.rules
+ # udev rule (in-game)
install -dm755 $pkgdir/etc/udev/rules.d/
echo 'KERNEL=="hidraw*", TAG+="uaccess"' > $pkgdir/etc/udev/rules.d/69-hid.rules
@@ -59,12 +59,12 @@ package() {
# binary
install -Dm755 src-tauri/target/release/$pkgname -t $pkgdir/usr/bin/
- # .desktop
+ # desktop file
install -Dm644 $srcdir/$pkgname.desktop -t $pkgdir/usr/share/applications/
# icons
for _size in 32x32 128x128 128x128@2x; do
- _iconpath=usr/share/icons/hicolor/$_size/apps
+ _iconpath=usr/share/icons/hicolor/$_size/apps/
install -Dm644 src-tauri/icons/$_size.png $pkgdir/$_iconpath/$pkgname.png
done