summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD37
-rw-r--r--yeahconsole_c.patch51
3 files changed, 111 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..53eac83f25d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = yeahconsole
+ pkgdesc = YeahConsole turns a terminal into a gamelike console. If you hit a shortcut it slides down from top of the screen.
+ pkgver = 0.3.4
+ pkgrel = 2
+ url = http://phrat.de/yeahtools.html
+ arch = i686
+ arch = x86_64
+ groups = yeahtools
+ license = GPL
+ makedepends = gcc
+ makedepends = make
+ depends = libx11
+ optdepends = xterm: yeahconsole needs a terminal
+ optdepends = rxvt-unicode: yeahconsole needs a terminal
+ source = http://phrat.de/yeahconsole-0.3.4.tar.gz
+ source = yeahconsole_c.patch
+ md5sums = 83a2367f9b4857fed02464b0e8a6595a
+ md5sums = d3216231337126dda5e97995e26dd487
+ sha256sums = fcf3481f78a263a70f1cb5163630fc22e78bb0915013eb05689c6f4aeb0583ef
+ sha256sums = d5dfe9143f7e81ad7ca4f9e7ca58d589193c6ece51c3d7ec39da64511497f855
+
+pkgname = yeahconsole
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b509247ccd0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Contributor: DonVla <donvla@users.sourceforge.net>
+
+pkgname=yeahconsole
+pkgver=0.3.4
+pkgrel=2
+pkgdesc="YeahConsole turns a terminal into a gamelike console. If you hit a shortcut it slides down from top of the screen."
+arch=(i686 x86_64)
+url="http://phrat.de/yeahtools.html"
+license=('GPL')
+groups=('yeahtools')
+depends=('libx11')
+optdepends=('xterm: yeahconsole needs a terminal' 'rxvt-unicode: yeahconsole needs a terminal')
+makedepends=('gcc' 'make')
+#install=
+source=(http://phrat.de/${pkgname}-${pkgver}.tar.gz yeahconsole_c.patch)
+md5sums=('83a2367f9b4857fed02464b0e8a6595a'
+ 'd3216231337126dda5e97995e26dd487')
+sha256sums=('fcf3481f78a263a70f1cb5163630fc22e78bb0915013eb05689c6f4aeb0583ef'
+ 'd5dfe9143f7e81ad7ca4f9e7ca58d589193c6ece51c3d7ec39da64511497f855')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+# uncomment to apply this patch
+# http://github.com/rduplain/yeahconsole/commit/22488002357cda40ddcc67df695f64f5b06a44a6 :
+# patch < ../yeahconsole_c.patch
+
+ make || return 1
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ install -D -m 0755 yeahconsole "${pkgdir}/usr/bin/yeahconsole"
+ install -D -m 0644 README "${pkgdir}/usr/share/yeahtools/yeahconsole.README"
+}
+# vim:set ts=2 sw=2 et:
diff --git a/yeahconsole_c.patch b/yeahconsole_c.patch
new file mode 100644
index 000000000000..982ae52a2051
--- /dev/null
+++ b/yeahconsole_c.patch
@@ -0,0 +1,51 @@
+--- yeahconsole.c.orig 2006-03-11 19:26:00.000000000 +0100
++++ yeahconsole.c 2009-09-19 11:43:07.000000000 +0200
+@@ -48,7 +48,7 @@
+ int revert_to;
+ int screen;
+ int opt_x, opt_width, opt_height, opt_delay, opt_bw, opt_step,
+- height, opt_restart;
++ height, opt_restart, opt_restart_hidden;
+ char *opt_color;
+ char *opt_term;
+ KeySym opt_key;
+@@ -72,7 +72,8 @@
+ XEvent event;
+ int hidden = 1;
+ int fullscreen = 0;
+- int i, old_height;
++ int i;
++ int old_height = 0;
+ Window last_focused, current_focused;
+
+ /* strip the path from argv[0] if there is one */
+@@ -190,10 +191,18 @@
+ case UnmapNotify:
+ if (event.xunmap.window == termwin) {
+ if (opt_restart) {
++ if (opt_restart_hidden) {
++ roll(UP);
++ hidden = 1;
++ }
+ init_xterm(0);
+ XSync(dpy, False);
+- XSetInputFocus(dpy, termwin, RevertToPointerRoot,
+- CurrentTime);
++ if (opt_restart_hidden && last_focused)
++ XSetInputFocus(dpy, last_focused,
++ RevertToPointerRoot, CurrentTime);
++ else
++ XSetInputFocus(dpy, termwin, RevertToPointerRoot,
++ CurrentTime);
+ } else {
+ if (last_focused)
+ XSetInputFocus(dpy, last_focused,
+@@ -264,6 +273,8 @@
+ opt_step = opt ? atoi(opt) : 1;
+ opt = XGetDefault(dpy, progname, "restart");
+ opt_restart = opt ? atoi(opt) : 0;
++ opt = XGetDefault(dpy, progname, "restartHidden");
++ opt_restart_hidden = opt ? atoi(opt) : 0;
+ opt = XGetDefault(dpy, progname, "term");
+ opt_term = opt ? opt : "xterm";
+ opt = XGetDefault(dpy, progname, "toggleKey");