summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 835415113d8e..8627b1d6e430 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = yegonesh
pkgdesc = Yeganesh-like dmenu wrapper written in Go
pkgver = 20151102
- pkgrel = 3
- url = http://github.com/klowner/yegonesh
+ pkgrel = 4
+ url = https://github.com/klowner/yegonesh
arch = x86_64
arch = i686
license = MIT
@@ -14,4 +14,3 @@ pkgbase = yegonesh
sha256sums = 5262fbea59aa1fa2cfd06b8642d44ff23586314cced8cb2b30f5cf7804a5f3fb
pkgname = yegonesh
-
diff --git a/PKGBUILD b/PKGBUILD
index 671d41e15d65..52d1968b18da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,32 @@
pkgname=yegonesh
pkgver=20151102
-pkgrel=3
+pkgrel=4
pkgdesc="Yeganesh-like dmenu wrapper written in Go"
arch=('x86_64' 'i686')
-url="http://github.com/klowner/yegonesh"
+url="https://github.com/klowner/yegonesh"
license=('MIT')
makedepends=('go')
depends=('dmenu')
options=('!strip' '!emptydirs')
source=(
- 'https://raw.githubusercontent.com/Klowner/yegonesh/master/main.go'
+ "https://raw.githubusercontent.com/Klowner/yegonesh/master/main.go"
)
sha256sums=(
'5262fbea59aa1fa2cfd06b8642d44ff23586314cced8cb2b30f5cf7804a5f3fb'
)
+prepare() {
+ go mod init "${url#https://}"
+ go mod tidy
+}
+
build() {
- go build -o "yegonesh"
+ go build -o "$pkgname"
}
package() {
- install -Dm755 "yegonesh" "$pkgdir/usr/bin/$pkgname"
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
}
# vim:set ts=2 sw=2 et: