summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--LICENSE15
-rw-r--r--PKGBUILD12
3 files changed, 27 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 041a6949bcad..6f06e0359007 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,7 @@ pkgbase = yosys-git
url = http://www.clifford.at/yosys/
arch = x86_64
arch = i686
- license = ISC
+ license = custom:ISC
makedepends = git
makedepends = mercurial
depends = tcl
@@ -16,7 +16,9 @@ pkgbase = yosys-git
provides = yosys
conflicts = yosys
source = git+https://github.com/cliffordwolf/yosys.git
+ source = LICENSE
sha512sums = SKIP
+ sha512sums = a3202289ff7828c55d3ec3e22d23ed78a34fcae165a7c666d71d3cedd9abe06f638a09750d8c2d43dfca5781f1b32a616f439c3713a12265c02473f88c0f426d
pkgname = yosys-git
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..d5b50f7fcf44
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,15 @@
+yosys -- Yosys Open SYnthesis Suite
+
+Copyright (C) 2012 - 2015 Clifford Wolf <clifford@clifford.at>
+
+Permission to use, copy, modify, and/or distribute this software for any
+purpose with or without fee is hereby granted, provided that the above
+copyright notice and this permission notice appear in all copies.
+
+THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 1f170cf111e0..a86e7ba9e8cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,14 +6,16 @@ pkgver=r2435.e51dcc8
pkgdesc='A framework for RTL synthesis'
arch=('x86_64' 'i686')
url='http://www.clifford.at/yosys/'
-license=('ISC')
+license=('custom:ISC')
provides=("yosys")
conflicts=("yosys")
depends=('tcl' 'libffi' 'clang' 'python')
optdepends=('graphviz: Schematics display support')
makedepends=('git' 'mercurial')
-source=('git+https://github.com/cliffordwolf/yosys.git')
-sha512sums=('SKIP')
+source=('git+https://github.com/cliffordwolf/yosys.git'
+ 'LICENSE')
+sha512sums=('SKIP'
+ 'a3202289ff7828c55d3ec3e22d23ed78a34fcae165a7c666d71d3cedd9abe06f638a09750d8c2d43dfca5781f1b32a616f439c3713a12265c02473f88c0f426d')
build(){
cd ${srcdir}/yosys
@@ -28,4 +30,8 @@ pkgver() {
package() {
cd ${srcdir}/yosys
make DESTDIR="$pkgdir/usr/" install
+
+ install -D -m 644 \
+ "${srcdir}/LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}