summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba881942b255..678bdec4d9a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = yq-bin
pkgdesc = a portable command-line YAML processor
- pkgver = 2.2.1
+ pkgver = 2.4.0
pkgrel = 1
url = https://github.com/mikefarah/yq
arch = x86_64
license = MIT
provides = yq
conflicts = yq
- source = https://github.com/mikefarah/yq/releases/download/2.2.1/yq_linux_amd64
- sha512sums = 2be7f80d3e022067000966f78dfac7601504e14b7500aa7b56833b84bd11a9907d699e2a74f7934c6ccc1f82646abbb4f1c29fe4bc0d31a086afd862afb65520
+ source = yq-2.4.0::https://github.com/mikefarah/yq/releases/download/2.4.0/yq_linux_amd64
+ sha256sums = 99a01ae32f0704773c72103adb7050ef5c5cad14b517a8612543821ef32d6cc9
pkgname = yq-bin
diff --git a/PKGBUILD b/PKGBUILD
index cec32c8a3c34..77ffc16102cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: E5ten <e5ten.arch@gmail.com>
pkgname=yq-bin
-pkgver=2.2.1
+pkgver=2.4.0
pkgrel=1
pkgdesc='a portable command-line YAML processor'
arch=('x86_64')
@@ -9,10 +9,10 @@ url='https://github.com/mikefarah/yq'
license=('MIT')
provides=('yq')
conflicts=('yq')
-source=("https://github.com/mikefarah/yq/releases/download/${pkgver}/yq_linux_amd64")
-sha512sums=('2be7f80d3e022067000966f78dfac7601504e14b7500aa7b56833b84bd11a9907d699e2a74f7934c6ccc1f82646abbb4f1c29fe4bc0d31a086afd862afb65520')
+source=("yq-${pkgver}::https://github.com/mikefarah/yq/releases/download/${pkgver}/yq_linux_amd64")
+sha256sums=('99a01ae32f0704773c72103adb7050ef5c5cad14b517a8612543821ef32d6cc9')
package() {
- install -Dm755 $srcdir/yq_linux_amd64 $pkgdir/usr/bin/yq
+ install -Dm755 "${srcdir}/yq-${pkgver}" "${pkgdir}/usr/bin/yq"
}