summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b853b3ed7d2d..18481f80aac1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yuzu-git
pkgdesc = An experimental open-source Nintendo Switch emulator/debugger
- pkgver = 5434.bf1084f
+ pkgver = r5516.1aa4cdc3
pkgrel = 1
url = https://github.com/citra-emu/citra/
arch = i686
@@ -18,6 +18,10 @@ pkgbase = yuzu-git
source = git+https://github.com/MerryMage/dynarmic
source = git+https://github.com/herumi/xbyak
source = git+https://github.com/fmtlib/fmt
+ source = git+https://github.com/svn2github/inih
+ source = git+https://github.com/yuzu-emu/unicorn
+ md5sums = SKIP
+ md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 42fd7da16f6a..44478adec2e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgbase='yuzu'
pkgbase="$_pkgbase-git"
pkgname=("$_pkgbase-git" "$_pkgbase-qt-git")
-pkgver=5434.bf1084f
+pkgver=r5516.1aa4cdc3
pkgrel=1
pkgdesc="An experimental open-source Nintendo Switch emulator/debugger"
arch=('i686' 'x86_64')
@@ -14,13 +14,17 @@ source=("$_pkgbase::git+https://github.com/yuzu-emu/yuzu"
'git+https://github.com/philsquared/Catch'
'git+https://github.com/MerryMage/dynarmic'
'git+https://github.com/herumi/xbyak'
- 'git+https://github.com/fmtlib/fmt')
+ 'git+https://github.com/fmtlib/fmt'
+ 'git+https://github.com/svn2github/inih'
+ 'git+https://github.com/yuzu-emu/unicorn')
md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP')
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
cd "$srcdir/$_pkgbase"
@@ -38,6 +42,7 @@ prepare() {
git config submodule.xbyak.url "$srcdir/xbyak"
git config submodule.fmt.url "$srcdir/fmt"
git config submodule.inih.url "$srcdir/inih"
+ git config submodule.unicorn.url "$srcdir/unicorn"
git submodule update
cd externals/dynarmic