summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-x.SRCINFO4
-rwxr-xr-xPKGBUILD12
2 files changed, 6 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a6e0d09f8b06..00e411f25ea3 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yuzu-git
pkgdesc = An experimental open-source emulator for the Nintendo Switch
- pkgver = r19935.720970c4c
+ pkgver = r21376.8037f2eae
pkgrel = 1
url = https://github.com/yuzu-emu/yuzu
arch = i686
@@ -39,7 +39,6 @@ pkgbase = yuzu-git
source = git+https://github.com/benhoyt/inih.git
source = git+https://github.com/kinetiknz/cubeb.git
source = git+https://github.com/MerryMage/dynarmic.git
- source = git+https://github.com/citra-emu/ext-soundtouch.git
source = libressl::git+https://github.com/citra-emu/ext-libressl-portable.git
source = git+https://github.com/libusb/libusb.git
source = git+https://github.com/discord/discord-rpc.git
@@ -70,6 +69,5 @@ pkgbase = yuzu-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
- md5sums = SKIP
pkgname = yuzu-git
diff --git a/PKGBUILD b/PKGBUILD
index af29040f1c7f..5819903c3cd4 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=yuzu
pkgname=$_pkgname-git
-pkgver=r19935.720970c4c
+pkgver=r21376.8037f2eae
pkgrel=1
pkgdesc='An experimental open-source emulator for the Nintendo Switch'
arch=('i686' 'x86_64')
@@ -40,7 +40,6 @@ source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu"
'git+https://github.com/benhoyt/inih.git'
'git+https://github.com/kinetiknz/cubeb.git'
'git+https://github.com/MerryMage/dynarmic.git'
- 'git+https://github.com/citra-emu/ext-soundtouch.git'
'libressl::git+https://github.com/citra-emu/ext-libressl-portable.git'
'git+https://github.com/libusb/libusb.git'
'git+https://github.com/discord/discord-rpc.git'
@@ -72,7 +71,6 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
'SKIP')
pkgver() {
@@ -83,10 +81,10 @@ pkgver() {
prepare() {
cd "$srcdir/$_pkgname"
- for submodule in externals/{inih/inih,cubeb,dynarmic,soundtouch,libressl,libusb/libusb,discord-rpc,Vulkan-Headers,sirit,mbedtls,xbyak,opus/opus,ffmpeg,SDL,cpp-httplib}; do
+ for submodule in externals/{inih/inih,cubeb,dynarmic,libressl,libusb/libusb,discord-rpc,Vulkan-Headers,sirit,mbedtls,xbyak,opus/opus,ffmpeg,SDL,cpp-httplib}; do
git submodule init ${submodule}
git config submodule.${submodule}.url "$srcdir/${submodule##*/}"
- git submodule update
+ git submodule update --init
done
cd "$srcdir/$_pkgname"/externals/cubeb
@@ -94,7 +92,7 @@ prepare() {
for submodule in cmake/sanitizers-cmake; do
git submodule init ${submodule}
git config submodule.${submodule}.url "$srcdir/${submodule##*/}"
- git submodule update
+ git submodule update --init
done
cd "$srcdir/$_pkgname"/externals/sirit
@@ -102,7 +100,7 @@ prepare() {
for submodule in externals/SPIRV-Headers; do
git submodule init ${submodule}
git config submodule.${submodule}.url "$srcdir/${submodule##*/}"
- git submodule update
+ git submodule update --init
done
}