summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-x.SRCINFO3
-rwxr-xr-xPKGBUILD9
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8acb82b07b44..39d4cd2c541d 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yuzu-git
pkgdesc = An experimental open-source Nintendo Switch emulator/debugger
- pkgver = r13623.aa3f9b960
+ pkgver = r14488.f24c67877
pkgrel = 1
url = https://github.com/yuzu-emu/yuzu/
arch = i686
@@ -16,6 +16,7 @@ pkgbase = yuzu-git
depends = qt5-multimedia
depends = qt5-tools
depends = libxkbcommon-x11
+ depends = libfdk-aac
optdepends = qt5-wayland: for Wayland support
provides = yuzu
provides = yuzu-cmd
diff --git a/PKGBUILD b/PKGBUILD
index a0dea2b92412..4633b5a3f255 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname='yuzu'
pkgname="$_pkgname-git"
-pkgver=r13623.aa3f9b960
+pkgver=r14488.f24c67877
pkgrel=1
pkgdesc="An experimental open-source Nintendo Switch emulator/debugger"
arch=('i686' 'x86_64')
@@ -17,7 +17,8 @@ depends=('shared-mime-info'
'qt5-base'
'qt5-multimedia'
'qt5-tools'
- 'libxkbcommon-x11')
+ 'libxkbcommon-x11'
+ 'libfdk-aac')
makedepends=('git'
'cmake'
'python2')
@@ -55,6 +56,10 @@ build() {
# Flag to fix SDL exceptions occurring in some users' builds
CXXFLAGS+=" -I/usr/include/SDL2 -D_REENTRANT -pthread -lSDL2"
+ # Temporary workaround for the issue 3754:
+ # https://github.com/yuzu-emu/yuzu/issues/3754
+ sed -i 's:-Werror=conversion::' src/video_core/CMakeLists.txt
+
mkdir -p build
cd build
cmake .. \