summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD19
2 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f7b571c88f4..cd031741d043 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zenity-light
- pkgdesc = Display graphical dialog boxes from shell scripts. Light version without WekKit2.
- pkgver = 3.43.0
+ pkgdesc = Display graphical dialog boxes from shell scripts - light version without WekKit2
+ pkgver = 3.44.0
pkgrel = 1
url = https://gitlab.gnome.org/GNOME/zenity
arch = x86_64
@@ -12,8 +12,7 @@ pkgbase = zenity-light
depends = libnotify
provides = zenity
conflicts = zenity
- options = debug
- source = git+https://gitlab.gnome.org/GNOME/zenity.git#commit=01e6d92f23f49414ba8ec4c5b3daf49222c1e31d
+ source = git+https://gitlab.gnome.org/GNOME/zenity.git#commit=7bf8c8910d34bfb2b883b32118b93b68d44dd77b
sha256sums = SKIP
pkgname = zenity-light
diff --git a/PKGBUILD b/PKGBUILD
index de3259c71847..1cce4cc9a14f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,12 @@
# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
# Contributor: Jan de Groot <jgc@archlinux.org>
-pkgname=zenity-light
-pkgver=3.43.0
+pkgname=zenity
+pkgname+="-light"
+pkgver=3.44.0
pkgrel=1
-pkgdesc="Display graphical dialog boxes from shell scripts. Light version without WekKit2."
+pkgdesc="Display graphical dialog boxes from shell scripts"
+pkgdesc+=" - light version without WekKit2"
url="https://gitlab.gnome.org/GNOME/zenity"
arch=(x86_64)
license=(LGPL)
@@ -13,7 +15,7 @@ depends=(gtk3 libnotify)
makedepends=(yelp-tools meson git)
conflicts=("${pkgname%-light}")
provides=("${pkgname%-light}")
-_commit=01e6d92f23f49414ba8ec4c5b3daf49222c1e31d # tags/3.43.0^0
+_commit=7bf8c8910d34bfb2b883b32118b93b68d44dd77b # tags/3.44.0^0
source=("git+https://gitlab.gnome.org/GNOME/zenity.git#commit=$_commit")
sha256sums=('SKIP')
@@ -27,9 +29,12 @@ prepare() {
}
build() {
- arch-meson zenity build \
- -D libnotify=true \
+ local meson_options=(
+ -D libnotify=true
-D webkitgtk=false
+ )
+
+ arch-meson zenity build "${meson_options[@]}"
meson compile -C build
}
@@ -40,3 +45,5 @@ check() {
package() {
meson install -C build --destdir "$pkgdir"
}
+
+# vim:set sw=2 sts=-1 et: