summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
-rw-r--r--zfs.install2
3 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8d70bf2520c..55cafffa33e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = zfs-linux-lts
- pkgver = 0.7.6.4.14.23.1
- pkgrel = 2
+ pkgver = 0.7.6.4.14.25.1
+ pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-lts-headers=4.14.23
+ makedepends = linux-lts-headers=4.14.25
makedepends = libelf
makedepends = spl-linux-lts-headers
depends = kmod
depends = spl-linux-lts
depends = zfs-utils-common=0.7.6
- depends = linux-lts=4.14.23
+ depends = linux-lts=4.14.25
source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.6/zfs-0.7.6.tar.gz
sha256sums = 1687f4041a990e35caccc4751aa736e8e55123b81d5f5a35b11916d9e580c23d
@@ -32,6 +32,8 @@ pkgname = zfs-linux-lts-headers
conflicts = zfs-linux-git-headers
conflicts = zfs-linux-threadripper-headers
conflicts = zfs-linux-threadripper-git-headers
+ conflicts = zfs-linux-threadripper-vfio-headers
+ conflicts = zfs-linux-threadripper-vfio-git-headers
conflicts = zfs-linux-vfio-headers
conflicts = zfs-linux-vfio-git-headers
conflicts = zfs-linux-zen-headers
diff --git a/PKGBUILD b/PKGBUILD
index 55dde389be0e..0d89311848f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,15 +18,15 @@
pkgbase="zfs-linux-lts"
pkgname=("zfs-linux-lts" "zfs-linux-lts-headers")
-pkgver=0.7.6.4.14.23.1
-pkgrel=2
-makedepends=("linux-lts-headers=4.14.23" "libelf" "spl-linux-lts-headers")
+pkgver=0.7.6.4.14.25.1
+pkgrel=1
+makedepends=("linux-lts-headers=4.14.25" "libelf" "spl-linux-lts-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.6/zfs-0.7.6.tar.gz")
sha256sums=("1687f4041a990e35caccc4751aa736e8e55123b81d5f5a35b11916d9e580c23d")
license=("CDDL")
-depends=("kmod" "spl-linux-lts" "zfs-utils-common=0.7.6" "linux-lts=4.14.23")
+depends=("kmod" "spl-linux-lts" "zfs-utils-common=0.7.6" "linux-lts=4.14.25")
build() {
cd "${srcdir}/zfs-0.7.6"
@@ -34,8 +34,8 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
--libexecdir=/usr/lib/zfs-0.7.6 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.14.23-1-lts/build \
- --with-linux-obj=/usr/lib/modules/4.14.23-1-lts/build
+ --with-linux=/usr/lib/modules/4.14.25-1-lts/build \
+ --with-linux-obj=/usr/lib/modules/4.14.25-1-lts/build
make
}
@@ -55,10 +55,10 @@ package_zfs-linux-lts() {
package_zfs-linux-lts-headers() {
pkgdesc="Kernel headers for the Zettabyte File System."
- conflicts=('zfs-archiso-linux-headers' 'zfs-archiso-linux-git-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' 'zfs-linux-threadripper-headers' 'zfs-linux-threadripper-git-headers' 'zfs-linux-vfio-headers' 'zfs-linux-vfio-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
+ conflicts=('zfs-archiso-linux-headers' 'zfs-archiso-linux-git-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' 'zfs-linux-threadripper-headers' 'zfs-linux-threadripper-git-headers' 'zfs-linux-threadripper-vfio-headers' 'zfs-linux-threadripper-vfio-git-headers' 'zfs-linux-vfio-headers' 'zfs-linux-vfio-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
cd "${srcdir}/zfs-0.7.6"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.14.23-1-lts/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.14.25-1-lts/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index 110d172e76ce..d3cebb171718 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.14.23-1-lts
+ depmod -a 4.14.25-1-lts
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'