summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD9
3 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c38f9afb3df3..f2831df38ae7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zig-git
pkgdesc = a programming language prioritizing robustness, optimality, and clarity
- pkgver = 0.9.0
+ pkgver = 0.9.0.r3052.g460211431
pkgrel = 1
url = https://ziglang.org
arch = i686
@@ -9,7 +9,7 @@ pkgbase = zig-git
makedepends = cmake
makedepends = git
depends = clang
- depends = llvm>=13
+ depends = llvm>=14
depends = lld
provides = zig
conflicts = zig
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..44d319eb49a6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!PKGBUILD
+!*.install
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 2d6a016b8104..9d62e5c9d107 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Marc Tiehuis <marctiehuis at gmail.com>
pkgname=zig-git
-pkgver=0.9.0
+pkgver=0.9.0.r3052.g460211431
pkgrel=1
pkgdesc="a programming language prioritizing robustness, optimality, and clarity"
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'aarch64')
url='https://ziglang.org'
license=('MIT')
-depends=('clang' 'llvm>=13' 'lld')
+depends=('clang' 'llvm>=14' 'lld')
makedepends=('cmake' 'git')
provides=(zig)
conflicts=(zig)
@@ -22,7 +22,8 @@ build() {
cmake -B build -S zig \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DZIG_PREFER_CLANG_CPP_DYLIB=ON
+ -DZIG_PREFER_CLANG_CPP_DYLIB=ON \
+ -DZIG_STATIC_ZLIB=on
cmake --build build
}