summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..39093596d93e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Thu May 12 15:48:26 UTC 2016
+pkgbase = znc-otr-git
+ pkgdesc = OTR (Off The Record) messaging for ZNC
+ pkgver = r57.ca696c9
+ pkgrel = 1
+ url = http://wiki.znc.in/Otr
+ arch = i686
+ arch = x86_64
+ license = Apache
+ depends = znc
+ depends = libotr
+ source = git+https://github.com/mmilata/znc-otr.git
+ sha256sums = SKIP
+
+pkgname = znc-otr-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..890ed05b58e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Joe Davison <joe@warhaggis.com>
+
+pkgname=znc-otr-git
+pkgver=r57.ca696c9
+pkgrel=1
+pkgdesc="OTR (Off The Record) messaging for ZNC"
+arch=('i686' 'x86_64')
+url="http://wiki.znc.in/Otr"
+license=('Apache')
+depends=('znc' 'libotr')
+source=("git+https://github.com/mmilata/znc-otr.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $srcdir/znc-otr
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd $srcdir/znc-otr
+ make
+}
+
+package() {
+ cd $srcdir/znc-otr
+
+ install -D -m755 otr.so "$pkgdir/usr/lib/znc/otr.so"
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+