summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ca2ab21780b..e01b56a431d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = zsh-history-substring-search-git
pkgdesc = A ZSH plugin to search history, a clean-room implementation of the Fish shell feature
- pkgver = 92.2f8a5f8
+ pkgver = 1.0.2.r8.g4abed97
pkgrel = 1
- epoch = 1
+ epoch = 2
url = https://github.com/zsh-users/zsh-history-substring-search
install = zsh-history-substring-search-git.install
arch = any
@@ -11,8 +11,7 @@ pkgbase = zsh-history-substring-search-git
depends = zsh
provides = zsh-history-substring-search
conflicts = zsh-history-substring-search
- source = git://github.com/zsh-users/zsh-history-substring-search
+ source = git+https://github.com/zsh-users/zsh-history-substring-search
md5sums = SKIP
pkgname = zsh-history-substring-search-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 9f9977a8e6f4..0a137a95f4c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
-# Maintainer: fsckd <fsckdaemon at gmail dot com>
+# Maintainer: Piotr Gorski <lucjan.lucjanov@gmail.com>
+# Contributor: fsckd <fsckdaemon at gmail dot com>
# Contributor: veox <veox at wre dot ath dot cx>
pkgname=zsh-history-substring-search-git
-pkgver=92.2f8a5f8
+pkgver=1.0.2.r8.g4abed97
pkgrel=1
-epoch=1
+epoch=2
pkgdesc="A ZSH plugin to search history, a clean-room implementation of the Fish shell feature"
arch=('any')
url="https://github.com/zsh-users/zsh-history-substring-search"
@@ -14,19 +15,21 @@ makedepends=('git')
provides=('zsh-history-substring-search')
conflicts=('zsh-history-substring-search')
install=zsh-history-substring-search-git.install
-source=('git://github.com/zsh-users/zsh-history-substring-search')
+source=('git+https://github.com/zsh-users/zsh-history-substring-search')
md5sums=('SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
- echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
local name="${pkgname%-git}"
cd "$srcdir/$name"
- install -d -m755 "$pkgdir/usr/share/zsh/plugins/$name"
- install -m644 README.md "$name".zsh "$pkgdir/usr/share/zsh/plugins/$name"
+ install -vDm 644 "${name}.zsh" \
+ -t "${pkgdir}/usr/share/zsh/plugins/${name}/"
+ # docs
+ install -vDm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}/"
}
# vim:set ts=2 sw=2 et: