summarylogtreecommitdiffstats
path: root/CMakeLists.txt.patch
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt.patch')
-rw-r--r--CMakeLists.txt.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/CMakeLists.txt.patch b/CMakeLists.txt.patch
new file mode 100644
index 000000000000..d0ffdf07a70f
--- /dev/null
+++ b/CMakeLists.txt.patch
@@ -0,0 +1,16 @@
+*** src/thrill/thrill/CMakeLists.txt 2020-12-12 18:07:24.931331282 +0000
+--- CMakeLists.txt 2020-12-12 20:32:33.608554570 +0000
+***************
+*** 48,51 ****
+--- 48,58 ----
+ target_include_directories(thrill SYSTEM PUBLIC ${THRILL_INCLUDE_DIRS})
+ target_link_libraries(thrill ${THRILL_LINK_LIBRARIES})
+
++ set(THRILL_HEADERS ${THRILL_SRCS})
++ list(FILTER THRILL_HEADERS INCLUDE REGEX "\\.hpp")
++
++ set_target_properties(thrill PROPERTIES PUBLIC_HEADER "${THRILL_HEADERS}")
++
++ INSTALL(TARGETS thrill LIBRARY DESTINATION lib PUBLIC_HEADER DESTINATION include/thrill)
++
+ ################################################################################