summarylogtreecommitdiffstats
path: root/Makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.patch')
-rw-r--r--Makefile.patch12
1 files changed, 9 insertions, 3 deletions
diff --git a/Makefile.patch b/Makefile.patch
index ee4d15d8e7f0..ed91d6f8026c 100644
--- a/Makefile.patch
+++ b/Makefile.patch
@@ -1,5 +1,5 @@
--- Makefile.dist 2016-07-18 15:28:52.000000000 +0200
-+++ Makefile 2017-05-27 13:56:10.325084225 +0200
++++ Makefile 2017-05-27 17:06:44.630971965 +0200
@@ -5,8 +5,9 @@
# try some automatic discovery
@@ -12,15 +12,21 @@
LUAROOT = $(shell dirname $(LUA_BINDIR))
# Defaults
-@@ -17,7 +18,6 @@
+@@ -15,9 +16,12 @@
+
+ CC = gcc
CFLAGS = -fPIC -Wall $(DEBUG)
++ifeq ($(LUA),lua)
LUA_INCDIR = $(LUAROOT)/include
++else
++LUA_INCDIR = $(LUAROOT)/include/lua$(LUAVERSION)
++endif
LUA_LIBDIR = $(LUAROOT)/lib
-LUA = lua
# OS specialities
ifeq ($(OS),Darwin)
-@@ -47,7 +47,7 @@
+@@ -47,7 +51,7 @@
cp $(TARGET) $(INST_LIBDIR)
test: all