summarylogtreecommitdiffstats
path: root/Makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.patch')
-rw-r--r--Makefile.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/Makefile.patch b/Makefile.patch
new file mode 100644
index 000000000000..0ac2af5231f8
--- /dev/null
+++ b/Makefile.patch
@@ -0,0 +1,24 @@
+--- src/mkdoc/Makefile 2010-08-02 16:01:09.361636372 +0000
++++ src/mkdoc-build/Makefile 2010-08-02 17:42:13.081860423 +0000
+@@ -1,4 +1,4 @@
+-PREFIX=/usr
++PREFIX?=/usr
+ DOCBOOKCSS=/usr/share/xml/docbook/xsl-stylesheets-1.75.2/html/docbook.xsl
+ DOCSRC=doc/top.mkdoc doc/mkdoc.conf
+ MKDOCFLAGS=
+@@ -7,11 +7,13 @@
+
+ all: docs
+
+-install: htmldoc
++install:
+ mkdir -p $(PREFIX)/bin
+ mkdir -p $(PREFIX)/share/mkdoc
+ cp -r src/* $(PREFIX)/share/mkdoc
+- ln -s $(PREFIX)/share/mkdoc/mkdoc $(PREFIX)/bin/mkdoc
++ ln -s /usr/share/mkdoc/mkdoc $(PREFIX)/bin/mkdoc
++
++install-doc: htmldoc
+ mkdir -p $(PREFIX)/share/doc/mkdoc
+ cp -r doc/html $(PREFIX)/share/doc/mkdoc
+