summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..8a9cea6e2ca4
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,21 @@
+DRIVER_NAME := goodix
+KERNEL_SOURCE_DIR ?= /lib/modules/`uname -r`/build
+
+EXTRA_CFLAGS +=
+
+obj-m := $(DRIVER_NAME).o
+
+#DRIVER_FILES := goodix.o
+
+#$(DRIVER_NAME)-objs:= $(DRIVER_FILES)
+
+modules:
+ $(MAKE) -C $(KERNEL_SOURCE_DIR) KCPPFLAGS="$(EXTRA_CFLAGS)" M=$(PWD) modules
+
+modules_install:
+ $(MAKE) -C $(KERNEL_SOURCE_DIR) M=$(PWD) modules_install
+
+install: modules_install
+
+clean:
+ $(MAKE) -C $(KERNEL_SOURCE_DIR) M=$(PWD) clean