summarylogtreecommitdiffstats
path: root/PKGBUILD.in
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD.in')
-rw-r--r--PKGBUILD.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD.in b/PKGBUILD.in
index 1e5dad0ba18e..f6b82ae69195 100644
--- a/PKGBUILD.in
+++ b/PKGBUILD.in
@@ -8,7 +8,7 @@ pkgdesc='Electronic schematic and printed circuit board (PCB) design tools'
arch=('x86_64')
url='http://kicad.org/'
license=('GPL')
-depends=('wxgtk3' 'python' 'boost-libs' 'glew' 'curl' 'glm' 'ngspice' 'opencascade' 'python-wxpython')
+depends=('wxwidgets-gtk3' 'python' 'boost-libs' 'glew' 'curl' 'glm' 'ngspice' 'opencascade' 'python-wxpython')
makedepends=('git' 'cmake' 'zlib' 'mesa' 'boost' 'swig' 'ninja' 'tar' 'gzip')
options=('!strip')
optdepends=(
@@ -52,10 +52,10 @@ build()
-DCMAKE_INSTALL_LIBDIR=/usr/lib/kicad-nightly/lib \
-DCMAKE_EXECUTABLE_SUFFIX=-nightly \
-DKICAD_USE_OCC=ON \
+ -DKICAD_USE_EGL=ON \
-DKICAD_SCRIPTING_WXPYTHON=ON \
-DKICAD_BUILD_I18N=ON \
-DKICAD_DATA=/usr/share/kicad-nightly \
- -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-gtk3 \
-Wno-dev
ninja
}