summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fc8cc37f13f1..3ef45dffe288 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,31 @@
-# Maintainer: ajs124 < aur AT ajs124 DOT de >
+# Maintainer: Bailey Fox <bfox200012@gmail.com>
+# Contributor: ajs124 < aur AT ajs124 DOT de >
# Contributor: Benoit Favre <benoit.favre@gmail.com>
# Contributor: Thomas Hebb <tommyhebb@gmail.com>
pkgname=abootimg-git
-pkgver=0.6.r6.g1ebeb39
+pkgver=r38.7e127fe
pkgrel=1
pkgdesc="A tool to read/write/update android boot images"
arch=('i686' 'x86_64' 'arm' 'armv7h')
-url="http://gitorious.org/ac100/abootimg"
+url="https://github.com/ggrandou/abootimg"
license=('GPL')
depends=('util-linux' 'cpio')
makedepends=('git')
provides=('abootimg')
-# upstream seems dead and gitorious is about to shut down -> use my mirror
-#source=('git+https://gitorious.org/ac100/abootimg.git')
-source=('git+https://gitlab.com/ajs124/abootimg.git')
-sha256sums=('SKIP')
+source=('git+https://github.com/ggrandou/abootimg.git'
+ 'no-initrd.patch')
+sha256sums=('SKIP'
+ '5fe9400e71f1ade170c1e0e99f343881edca2022300c7e7a1d34d776c22cc126')
pkgver() {
cd "abootimg"
- git describe --long --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${srcdir}/abootimg"
+ patch -p0 --binary < ../no-initrd.patch
}
build() {