summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd4d65fe3792
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Kevin Houdebert <kevin@qwazerty.eu>
+
+_pkgname=acbuild
+pkgname=acbuild-git
+pkgver=0.2.2
+pkgrel=1
+pkgdesc='Command line utility to build and modify App Container Images (ACIs), the container image format defined in the App Container (appc) spec.'
+url='https://github.com/appc/acbuild'
+license=('Apache')
+arch=('i686' 'x86_64')
+depends=('gnupg')
+makedepends=('git' 'go')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=('git+https://github.com/appc/acbuild.git')
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/$_pkgname"
+ ./build
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+
+ install -Dm755 bin/acbuild "$pkgdir/usr/bin/acbuild"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+}