summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 16 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 593c400b4d8e..00104c2cbdfc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,10 @@
-# Maintainer mober <maxATmoberDOTat>
-# Thanks to:
-# * Yuen Hoe (Jason moofang) / jasonmoofang@github
-# https://github.com/jasonmoofang/activityfox
-# * Leonid Kalichkin / hellishnoob@github
-# https://github.com/hellishnoob/activityfox
+# Maintainer:
+# Contributor: Felix Golatofski <contact@xdfr.de>
+# Contributor: mober <maxATmoberDOTat>
-pkgname=activityfox-git
_pkgname=activityfox
-pkgver=0.2
+pkgname=$_pkgname-git
+pkgver=0.2.r3.g2c84c52
pkgrel=1
pkgdesc="allow Firefox to play nice with KDE Plasma Activities"
arch=('i686' 'x86_64')
@@ -15,18 +12,23 @@ url="https://github.com/temporaryname96/activityfox"
license=('GPL3')
depends=('firefox')
makedepends=('automoc4')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
source=("git+${url}.git")
sha256sums=('SKIP')
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
build() {
- cd $srcdir/${_pkgname}
- cmake .
- make
+ cd "$srcdir/$_pkgname"
+ cmake .
+ make
}
package() {
- cd $srcdir/$_pkgname
-
- install -D -t ${pkgdir}/usr/bin activityfox activityfox.shell
+ cd "$srcdir/$_pkgname"
+ install -D -t ${pkgdir}/usr/bin activityfox activityfox.shell
}