summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 18 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8a82d2ad3bf1..224fd874093b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,31 @@
# Maintainer: Christopher Arndt <chris at chrisarndt.de>
# Contributor: Jelle van der Waa <jelle@vdwaa.nl>
-pkgname='adafruit-ampy'
-pkgver=1.0.7
-pkgrel=3
-pkgdesc="Utility to interact with a CircuitPython or MicroPython board over a serial connection."
-url="https://github.com/scientifichackers/ampy"
-arch=('any')
-license=('MIT')
-depends=('python-click' 'python-pyserial' 'python-dotenv')
-makedepends=('python-setuptools-scm')
-provides=('python-ampy' 'ampy')
-source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-sha512sums=('097f67915636c5491be98572c42782e9e98a14c4e37a6041f199b310790383e48fb61cf3d98b2d2902f01e3bbdc1f345b8c70c17a2a0eb62894c3a05cf1aa67f')
+pkgname=adafruit-ampy
+pkgver=1.1.0
+pkgrel=1
+pkgdesc='Utility to interact with a CircuitPython or MicroPython board over a serial connection'
+url='https://github.com/scientifichackers/ampy'
+arch=(any)
+license=(MIT)
+makedepends=(python-build python-installer python-setuptools python-wheel)
+depends=(python-click python-pyserial python-dotenv)
+provides=(python-ampy ampy)
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=('f4cba36f564096f2aafd173f7fbabb845365cc3bb3f41c37541edf98b58d3976')
build() {
- cd "${srcdir}/adafruit-ampy-${pkgver}"
-
- python setup.py build
+ cd $pkgname-$pkgver
+ python -m build --wheel --no-isolation
}
package() {
- cd "${srcdir}/adafruit-ampy-${pkgver}"
-
- python setup.py install --root="$pkgdir/" --skip-build --optimize=1
+ cd $pkgname-$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
# install documentation
- install -Dm644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm644 README.md -t "$pkgdir"/usr/share/doc/$pkgname
# install license
- install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
}
# vim:set ts=2 sw=2 et: