summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 25 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 55f3aef54c40..54e98cf70357 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ant-gtk-theme
pkgver=1.1.0
-pkgrel=6
+pkgrel=7
pkgdesc="Ant Theme for GTK 3.x"
arch=(any)
url=https://www.gnome-look.org/p/1099856
@@ -10,35 +10,34 @@ url=https://www.gnome-look.org/p/1099856
depends=('gtk3')
_hash_time=($(curl -s "$url"|grep -e "hash =" -e "timetamp ="|sed "s/.*= '\(.*\)';/\1/"))
-source=("https://dl.opendesktop.org/api/files/downloadfile/id/1525899974/s/${_hash_time[0]}/t/${_hash_time[1]}/u/Ant.tar"
- "https://dl.opendesktop.org/api/files/downloadfile/id/1526696980/s/${_hash_time[0]}/t/${_hash_time[1]}/u/Ant-Bloody.tar"
- "https://dl.opendesktop.org/api/files/downloadfile/id/1525239130/s/${_hash_time[0]}/t/${_hash_time[1]}/u/Ant-Nebula.tar"
- "https://dl.opendesktop.org/api/files/downloadfile/id/1525239091/s/${_hash_time[0]}/t/${_hash_time[1]}/u/Ant-Dracula.tar"
- "https://dl.opendesktop.org/api/files/downloadfile/id/1525239087/s/${_hash_time[0]}/t/${_hash_time[1]}/u/Ant-Dracula-slim.tar.xz"
- "https://dl.opendesktop.org/api/files/downloadfile/id/1525239127/s/${_hash_time[0]}/t/${_hash_time[1]}/u/Ant-Nebula-slim.tar.xz"
- "https://dl.opendesktop.org/api/files/downloadfile/id/1526696975/s/${_hash_time[0]}/t/${_hash_time[1]}/u/Ant-Bloody-slim.tar.xz"
- "https://dl.opendesktop.org/api/files/downloadfile/id/1525899970/s/${_hash_time[0]}/t/${_hash_time[1]}/u/Ant-slim.tar.xz")
-
-sha256sums=('c7e3b91ec8aae66cfe3de15a4595d3413575b7d7d410ff01f479a89a0af72cbb'
- '049ad2d833045c746d68770f7182d08ab2e08906b85281c9bbfac0289fc8709b'
- '0b7d05c11c8f4a50f09dae2555f691e68fede837cd839d735fd750bc3175c57d'
- '203be8c1bc88598f7e72b26affe14e86bb98f99f8a43acdf48b7f40e6ed79d2b'
- '4874d244df55e7caf15623d8bff0e03318c917ff09a0af2c9498dcd6adc00451'
- 'f81cd6b8c0845a41d416beaca1a0c93d171a0231e3e707469cb38d7a670f47e9'
- '7d18cefffc6627d14013919d6c4f0c0b52148dbfad920d8f656c33850a90972f'
- '3c4f359233e03b2658da380f28a051d25bffaa9f9eb556842f22e2f54f9eba7a')
+source=("https://dl.opendesktop.org/api/files/downloadfile/id/1533245814/s/${_hash_time[0]}/t/${_hash_time[1]}/u/Ant.tar"
+ "https://dl.opendesktop.org/api/files/downloadfile/id/1533875341/s/${_hash_time[0]}/t/${_hash_time[1]}/u/Ant-Bloody.tar"
+ "https://dl.opendesktop.org/api/files/downloadfile/id/1533245870/s/${_hash_time[0]}/t/${_hash_time[1]}/u/Ant-Nebula.tar"
+ "https://dl.opendesktop.org/api/files/downloadfile/id/1533245854/s/${_hash_time[0]}/t/${_hash_time[1]}/u/Ant-Dracula.tar"
+ "https://dl.opendesktop.org/api/files/downloadfile/id/1533277541/s/${_hash_time[0]}/t/${_hash_time[1]}/u/Ant-Dracula-slim.tar.xz"
+ "https://dl.opendesktop.org/api/files/downloadfile/id/1533277561/s/${_hash_time[0]}/t/${_hash_time[1]}/u/Ant-Nebula-slim.tar.xz"
+ "https://dl.opendesktop.org/api/files/downloadfile/id/1533875433/s/${_hash_time[0]}/t/${_hash_time[1]}/u/Ant-Bloody-slim.tar.xz"
+ "https://dl.opendesktop.org/api/files/downloadfile/id/1533277517/s/${_hash_time[0]}/t/${_hash_time[1]}/u/Ant-slim.tar.xz")
+sha256sums=('26cf6832bb1b0bc595896dee045c252dca65f12d32f0ba8e641ac152913abed8'
+ 'aefdfd5cbde815b369b16f474b6bf13c4839904d9c2b2b2a5df0828226cfcbf0'
+ 'bd86338e75f697c360b64c9a766d059ca79787e5364d8cd75a42f67fbf90ec46'
+ '8977b0b528b2306cdc92419f9caf34818cd2ac64eff18991eab7e16e422eeb5e'
+ '145713bd96146ac61262bf38ee87554adc4e170fc524d3718f3d22508b07b061'
+ 'fabdc3003dc5003ffbfd0b74148e32318d22e53411c5278bf4f3f93f3cdb00df'
+ '21717394faafe7ab177b67f158b0ef291c6ef6bb78272c87d40e560c469dbafe'
+ '514f26401bbd4db1ccec413e88035c1bb9a0f4547c10e97874d52a98ed7f171c')
package() {
cd ${srcdir}
find Ant{,-Bloody,-Dracula,-Nebula}/ -type f -exec install -Dm644 '{}' "${pkgdir}/usr/share/themes/{}" \;
# break out '-Slim' and '-standard-buttons' sub-dirs
- cp -r "${srcdir}/Ant-Slim/Ant-Slim" "${pkgdir}/usr/share/themes/"
- cp -r "${srcdir}/Ant-Slim/Ant-Slim-Standard-buttons" "${pkgdir}/usr/share/themes/"
- cp -r "${srcdir}/Ant-Bloody-Slim/Ant-Bloody-Slim" "${pkgdir}/usr/share/themes/"
- cp -r "${srcdir}/Ant-Bloody-Slim/Ant-Bloody-Slim-standard-buttons" "${pkgdir}/usr/share/themes/"
- cp -r "${srcdir}/Ant-Dracula-Slim/Ant-Dracula-Slim" "${pkgdir}/usr/share/themes/"
- cp -r "${srcdir}/Ant-Dracula-Slim/Ant-Dracula-Slim-standard-buttons" "${pkgdir}/usr/share/themes/"
- cp -r "${srcdir}/Ant-Nebula-Slim/Ant-Nebula-Slim" "${pkgdir}/usr/share/themes/"
- cp -r "${srcdir}/Ant-Nebula-Slim/Ant-Nebula-Slim-standard-buttons" "${pkgdir}/usr/share/themes/"
+ cp -r "${srcdir}/Ant-slim/Ant-slim" "${pkgdir}/usr/share/themes/"
+ cp -r "${srcdir}/Ant-slim/Ant-slim-standard-buttons" "${pkgdir}/usr/share/themes/"
+ cp -r "${srcdir}/Ant-Bloody-slim/Ant-Bloody-Slim" "${pkgdir}/usr/share/themes/"
+ cp -r "${srcdir}/Ant-Bloody-slim/Ant-Bloody-slim-standard-buttons" "${pkgdir}/usr/share/themes/"
+ cp -r "${srcdir}/Ant-Dracula-slim/Ant-Dracula-slim" "${pkgdir}/usr/share/themes/"
+ cp -r "${srcdir}/Ant-Dracula-slim/Ant-Dracula-slim-standard-buttons" "${pkgdir}/usr/share/themes/"
+ cp -r "${srcdir}/Ant-Nebula-slim/Ant-Nebula-slim" "${pkgdir}/usr/share/themes/"
+ cp -r "${srcdir}/Ant-Nebula-slim/Ant-Nebula-slim-standard-buttons" "${pkgdir}/usr/share/themes/"
}