summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 9 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e6e84b3d9b5e..bdb422c06b82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,45 +13,39 @@
pkgname=apache-mod_bw
_pkgname=mod_bw
-pkgver=0.7
-pkgrel=3
+pkgver=0.92
+pkgrel=1
pkgdesc="DSO module for Apache that throttles HTTP traffic"
-url="http://bwmod.sourceforge.net"
+url="http://ivn.cl/category/apache/"
arch=('i686' 'x86_64')
license=('apache')
depends=('apache')
makedepends=('apache')
install="$pkgname.install"
-source=("http://bwmod.sourceforge.net/files/$_pkgname-$pkgver.tgz"
- 'apr_atomic_fix.patch'
+source=("http://ivn.cl/files/source/$_pkgname-$pkgver.tgz"
'apache24.patch')
-md5sums=('d792a892517ca89f21ac2a6c01e6ccb2'
- 'f9cdca58c58678a2e334086ccf81f898'
+md5sums=('90f5e632dad5de8d49dcdb61453dcf97'
'23f29e631f65ba05e650a5b0cf57dba7')
_MODDIR='usr/lib/httpd/modules'
_DOCDIR="usr/share/doc/$pkgname"
prepare() {
- cd $srcdir/$_pkgname
-
- # fix for undefined symbol errors:
- # http://4j.blogspot.com/2008/09/fix-for-modbw-when-getting-error.html
- patch < "$srcdir"/apr_atomic_fix.patch
+ cd "$srcdir"
# fix for apache 2.4
patch < "$srcdir"/apache24.patch
}
-
+
build() {
- cd $srcdir/$_pkgname
+ cd "$srcdir"
# make the module
/usr/sbin/apxs -c -o $_pkgname.so $_pkgname.c
}
package() {
- cd $srcdir/$_pkgname
+ cd "$srcdir"
install -Dm644 .libs/$_pkgname.so $pkgdir/$_MODDIR/$_pkgname.so