summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c9cecbad28b1..b8901fc897e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Alexandre Bouvier <contact@amb.tf>
_pkgname=apotris
pkgname=$_pkgname-git
-pkgver=3.4.6.r816.gdf78baf
+pkgver=4.0.1.r31.gc696f0d
pkgrel=1
pkgdesc="A block stacking puzzle game for the Game Boy Advance (Linux port)"
arch=('aarch64' 'armv7h' 'i486' 'i686' 'pentium4' 'x86_64')
url="https://apotris.com/"
-license=('GPL-3.0-only')
+license=('AGPL-3.0-only')
depends=('bash' 'glibc' 'sdl2')
makedepends=(
'git'
@@ -21,9 +21,9 @@ makedepends=(
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
source=(
- "$_pkgname::git+https://gitea.com/akouzoukos/apotris.git#branch=ports"
- 'soloud::git+https://github.com/akouzoukos/soloud.git'
- 'Tilengine::git+https://github.com/akouzoukos/Tilengine.git'
+ "$_pkgname::git+https://gitea.com/akouzoukos/apotris.git"
+ 'SoLoud::git+https://gitea.com/Apotris/SoLoud.git'
+ 'Tilengine::git+https://gitea.com/Apotris/Tilengine.git'
"$_pkgname.sh"
"$_pkgname-install.patch"
"$_pkgname-use-system-libs.patch"
@@ -34,9 +34,9 @@ b2sums=(
'SKIP'
'SKIP'
'6a5b652537461135895820391beb20bb2e64e312f08ddbd9ea8d313047118693556df26e89019e81b26c6650388597eebbc8ae4cf824739aadb41121d728ed80'
- '1f420289881132aac8bda86c512d5c8af7c359561bc88bae6c0e3ba24bce71642d5f62e37163b38bb9ca28e2f4bab7cda4b5de1d952bb5029f2bdeb5fc90147a'
- 'd8aff212300b4150f4b5c383c9258e1c0976680fb9fff412eb1f9747e041e83ddda41ae428b95d327cb4879450d45dd09acff6f96a1d453f103968182f72f659'
- '497d9ed7ed0c5d3bce10d23a14e5a6d4b39125045290048f8a4b813fd81767f9a459636c5e84fd17b3b0802fee6fd0afa0bddb0dbda7c04484a39a2bc176a0ba'
+ '9c5ae4c3ed156cddf6d5caca13d2c8f5afb30e9923e606fe6f2a1dbb654686187ed82cf0155518a726077d49722263e8373fbcea62ac0c978f1e15b888784414'
+ '45ac59964e9426f887ae151986da55aa1a3ff35359c7b09db6418bbb422ea34b03900d95cd77ce8973dfc486c8246cd05bb44c45975534f46da695539a3210b0'
+ '287d56bc52fa3de3dcf9d89a5d104f520c2cc8a0cda4ac3021dee8b0cd0ef38235290cda2f3a84da75d2623e228df2d3a1b4fa6a50565fca5200b1386680e26d'
)
pkgver() {
@@ -46,7 +46,7 @@ pkgver() {
prepare() {
cd $_pkgname
- git config submodule.subprojects/SoLoud.url ../soloud
+ git config submodule.subprojects/SoLoud.url ../SoLoud
git config submodule.tilengine.url ../Tilengine
git -c protocol.file.allow=always submodule update
patch -Np1 < ../$_pkgname-use-system-libs.patch