summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 74cd78dc6ec9..825bc7fa4df0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Sebastian J. Bronner <waschtl@sbronner.com>
pkgname=aqbanking-git
-pkgver=5.99.35beta
+pkgver=5.99.43beta+10+gfe9dcc2b
pkgrel=1
pkgdesc="A library for online banking and financial applications"
arch=(x86_64 i686)
@@ -24,10 +24,18 @@ prepare() {
}
build() {
- $_sourcedir/configure --prefix=/usr --enable-gwenhywfar --with-backends="aqhbci aqofxconnect"
+ # The targets typedefs and types need to be built when building from GIT
+ # (README:239-246). The README file mistakenly specifies to run configure
+ # after these. They require configure to have been run. As of version
+ # 5.99.43beta+10+gfe9dcc2b these targets break building outside of the source
+ # tree (as is my custom to do). That is why I am using cd $_sourcedir.
+ cd $_sourcedir
+ ./configure --prefix=/usr --enable-gwenhywfar --with-backends="aqhbci aqofxconnect"
+ make typedefs
+ make types
make
}
package() {
- make DESTDIR=$pkgdir install
+ make -C $_sourcedir DESTDIR=$pkgdir install
}