summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26a1018f00f2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: haha662 <haha662 at outlook dot com>
+
+pkgname=arch-texdoc-git
+pkgver=r3.5fe70bf
+pkgrel=1
+pkgdesc="Drop-in replacement of texdoc for Arch Linux using online documents"
+arch=("any")
+url="https://github.com/haha662/arch-texdoc"
+license=("MIT")
+depends=("python" "xdg-utils")
+makedepends=("git")
+source=("$pkgname::git+https://github.com/haha662/arch-texdoc.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${pkgname}"
+
+ install -Dm755 arch-texdoc.py "${pkgdir}/usr/bin/arch-texdoc"
+}