summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a801894a6782..03b75a92cc07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Calimero <calimerotekni@free.fr>
pkgname=aufs-util
-pkgver=20150511
+pkgver=20160301
pkgrel=1
pkgdesc="Another Unionfs Implementation that supports NFS branches"
arch=('i686' 'x86_64')
@@ -14,15 +14,15 @@ source=("${pkgname}::git://git.code.sf.net/p/aufs/aufs-util")
md5sums=('SKIP')
pkgver() {
- cd "${pkgname}"
- # Checkout the latest branch
- git checkout -q "$(git for-each-ref --format='%(refname:short)' --sort=-refname:short "*/*/*/aufs[0-9].[0-9]*" --count=1)"
+ cd "${srcdir}/${pkgname}"
date -d @$(git log -n1 --pretty=format:%ct) '+%Y%m%d'
}
prepare() {
cd "${srcdir}/${pkgname}"
- sed -i 's/($|\\\\.x)/($|\\\\.x|-[0-9]*$)/' ver.c
+
+ # Checkout the latest branch
+ git checkout "$(git for-each-ref --format='%(refname:short)' --sort=-refname:short "*/*/*/aufs[0-9].[0-9]*" --count=1)"
}
build() {