summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD15
1 files changed, 2 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 44bdc76ab1c2..217fa2e39539 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=augur-git
_gitname=augur-app
_pkgname=augur
-pkgver=v1.7.1
+pkgver=v1.9.2
pkgrel=1
pkgdesc="Augur Desktop Application"
arch=('any')
@@ -11,7 +11,7 @@ license=('MIT')
depends=('gconf' 'electron')
conflicts=('augur')
provides=('augur')
-makedepends=('git' 'npm' 'nvm')
+makedepends=('git' 'npm')
source=("${_gitname}::git+https://github.com/AugurProject/$_gitname.git"
"${_pkgname}.desktop")
sha512sums=('SKIP'
@@ -26,19 +26,8 @@ pkgver() {
build() {
cd "$srcdir/$_gitname"
- _npm_prefix=$(npm config get prefix)
- npm config delete prefix
-
- # Switch to required node version see https://github.com/AugurProject/augur-app/issues/72
- source /usr/share/nvm/init-nvm.sh --install
- nvm install 9 && nvm use 9
-
npm install
npm run make-linux dir --dir
-
- # Restore config
- npm config set prefix ${_npm_prefix}
- nvm unalias default
}
package(){