summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 27 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ea7e0042a542..9e672370aef7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,40 @@
-# Maintainer: Mike Hicklen <mike@xfs.repair>
+# Maintainer: JP Roemer <jp+aur@roemer.im>
+# Contributor: Mike Hicklen <mike@xfs.repair>
+# Contributor: David Birks <david@birks.dev>
pkgname=aws-iam-authenticator
-pkgver=0.6.9
+pkgver=0.6.14
pkgrel=1
pkgdesc='A tool to use AWS IAM credentials to authenticate to a Kubernetes cluster'
arch=('x86_64' 'aarch64')
url='https://github.com/kubernetes-sigs/aws-iam-authenticator'
-license=('Apache')
+license=('Apache-2.0')
makedepends=('go')
-conflicts=('aws-iam-authenticator-bin' 'aws-iam-authenticator-git')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/kubernetes-sigs/aws-iam-authenticator/archive/v$pkgver.tar.gz")
-sha512sums=('8fb7b4803f20f1311b19c88cef1497017ff05ac5009309acc307c8befd219fc80815d281c2e3d139d0fe507e4ac4ed966be607347bd0298e6826b9be76b73873')
+provides=("${pkgname}")
+conflicts=("${pkgname}-bin" "${pkgname}-git")
+source=("${pkgname}_${pkgver}.tar.gz::https://github.com/kubernetes-sigs/aws-iam-authenticator/archive/v$pkgver.tar.gz")
+sha512sums=('26a6b394fbe767910f605a356032338a4ec254b81cd470796e3137e3595fef338bd213dee8d956c8d23e16f5508741e78664cd0f8b1acd97321d2fb5b7b723af')
+
+export GGO_ENABLED="0"
+export CGO_CPPFLAGS="${CPPFLAGS}"
+export CGO_CFLAGS="${CFLAGS}"
+export CGO_CXXFLAGS="${CXXFLAGS}"
+export CGO_LDFLAGS="${LDFLAGS}"
+export GOFLAGS="-trimpath -mod=readonly -modcacherw"
build() {
- cd $pkgname-$pkgver
- go build \
- --trimpath \
- --ldflags "-X main.version=$pkgver" \
- ./cmd/aws-iam-authenticator
+ local _commit _flags
+ _commit=$(bsdcat "${pkgname}_${pkgver}.tar.gz" | git get-tar-commit-id)
+ _flags=(
+ -X=sigs.k8s.io/aws-iam-authenticator/pkg.Version="v${pkgver}"
+ -X=sigs.k8s.io/aws-iam-authenticator/pkg.CommitID="${_commit}"
+ -X=sigs.k8s.io/aws-iam-authenticator/pkg.BuildDate="$(date -u +"%Y-%m-%dT%H:%M:%SZ")"
+ )
+ cd "${pkgname}-${pkgver}"
+ go build -o "${pkgname}" -ldflags="-s -w ${_flags[*]}" "./cmd/${pkgname}"
}
package() {
- install -Dm 755 "$srcdir/$pkgname-$pkgver/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ cd "${pkgname}-${pkgver}"
+ install -Dm 755 "${pkgname}" -t "${pkgdir}/usr/bin"
}