summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 19 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 35f1888aaee1..dceb7e9ea450 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,8 @@
# Contributor: HÃ¥vard Pettersson <mail@haavard.me>
# Contributor: Andrew Stubbs <andrew.stubbs@gmail.com>
-pkgname=etcher
+pkgname=balena-etcher
+_pkgname=etcher
pkgver=1.5.35
pkgrel=1
pkgdesc='Flash OS images to SD cards & USB drives, safely and easily'
@@ -13,25 +14,28 @@ depends=(electron gtk2 libxtst libxss gconf nss alsa-lib)
makedepends=(npm python2 git jq)
optdepends=('libnotify: for notifications'
'speech-dispatcher: for text-to-speech')
+conflicts=("${_pkgname}"
+ "${_pkgname}-bin"
+)
options=('!strip')
-source=("${pkgname}::git+https://github.com/balena-io/${pkgname}.git#tag=v${pkgver}"
+source=("${_pkgname}::git+https://github.com/balena-io/${_pkgname}.git#tag=v${pkgver}"
'git+https://github.com/balena-io/scripts.git'
- 'etcher-electron'
- 'etcher-electron.desktop')
+ "${pkgname}-electron"
+ "${pkgname}-electron.desktop")
sha256sums=('SKIP'
'SKIP'
'4499f316e4de865696312b31545f8df62850aad4492bcc9736cccb6d8eeb96ec'
'89291532fb6e6c5555b43d61c9ba3df103bca0eace040483884b86fd30dca3e4')
prepare() {
- cd "${pkgname}"
+ cd "${_pkgname}"
git submodule init
git config submodule.scripts/resin.url "${srcdir}/scripts"
git submodule update
}
build() {
- cd "${pkgname}"
+ cd "${_pkgname}"
export NPM_VERSION=$(npm --version)
make electron-develop
make webpack
@@ -39,23 +43,23 @@ build() {
}
package() {
- cd "${pkgname}"
+ cd "${_pkgname}"
- _appdir="${pkgdir}"/usr/lib/${pkgname}
+ _appdir="${pkgdir}/usr/lib/${pkgname}"
install -d "${_appdir}"
install package.json "${_appdir}"
cp -a {lib,generated,node_modules} "${_appdir}"
- install -D assets/icon.png "${_appdir}"/assets/icon.png
- install -D lib/gui/app/index.html "${_appdir}"/lib/gui/app/index.html
+ install -D assets/icon.png "${_appdir}/assets/icon.png"
+ install -D lib/gui/app/index.html "${_appdir}/lib/gui/app/index.html"
- install -Dm755 "${srcdir}"/etcher-electron "${pkgdir}"/usr/bin/etcher-electron
- install -Dm644 "${srcdir}"/etcher-electron.desktop \
- "${pkgdir}"/usr/share/applications/etcher-electron.desktop
+ install -Dm755 "${srcdir}/${pkgname}-electron" "${pkgdir}/usr/bin/${pkgname}-electron"
+ install -Dm644 "${srcdir}/${pkgname}-electron.desktop" \
+ "${pkgdir}/usr/share/applications/${pkgname}-electron.desktop"
for size in 16x16 32x32 48x48 128x128 256x256 512x512; do
- install -Dm644 assets/iconset/${size}.png \
- "${pkgdir}"/usr/share/icons/hicolor/${size}/apps/etcher-electron.png
+ install -Dm644 "assets/iconset/${size}.png" \
+ "${pkgdir}/usr/share/icons/hicolor/${size}/apps/${pkgname}-electron.png"
done
}