summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 48418bb330ec..f1b5b5b3f6d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=balena-etcher
_pkgname=etcher
pkgver=1.5.70
-pkgrel=1
+pkgrel=2
epoch=2
pkgdesc='Flash OS images to SD cards & USB drives, safely and easily'
arch=(x86_64)
@@ -21,12 +21,12 @@ conflicts=("${_pkgname}"
"${_pkgname}-bin"
)
options=('!strip')
-source=("${_pkgname}::git+https://github.com/balena-io/${_pkgname}.git#tag=v${pkgver}"
+source=("https://github.com/balena-io/${_pkgname}/archive/v${pkgver}.tar.gz"
'git+https://github.com/balena-io/scripts.git'
"${pkgname}-electron"
"${pkgname}-electron.desktop"
)
-sha256sums=('SKIP'
+sha256sums=('9c66bbbb709e70560cd831668de1d1aa6f581d647e6591c154edeff8474769c2'
'SKIP'
'911cca26a477c0525085410c78cd9292dc4b6bd27fb7340034fe762d333a3f52'
'c950d9578f9cf60998c920bb60c6617559963f06a4918e7072fdc706b0ef5754')
@@ -49,7 +49,6 @@ build() {
package() {
cd "${_pkgname}"
- find "${pkgdir}" -name package.json -print0 | xargs -r -0 sed -i '/_where/d'
_appdir="${pkgdir}/usr/lib/${pkgname}"
install -d "${_appdir}"
@@ -66,6 +65,8 @@ package() {
install -Dm644 "assets/iconset/${size}.png" \
"${pkgdir}/usr/share/icons/hicolor/${size}/apps/${pkgname}-electron.png"
done
+
+ find "${pkgdir}" -name package.json -print0 | xargs -r -0 sed -i '/_where/d'
}
# vim:set ts=2 sw=2 et: