summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 317b2e397151..396fc4fa056b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=etcher
pkgver=1.3.1
-pkgrel=2
+pkgrel=3
pkgdesc='Burn images to SD cards & USB drives, safe & easy'
arch=(x86_64)
url='https://www.etcher.io/'
@@ -13,9 +13,11 @@ makedepends=(npm python2 git)
optdepends=('libnotify: for notifications'
'speech-dispatcher: for text-to-speech')
source=("https://github.com/resin-io/$pkgname/archive/v$pkgver.tar.gz"
- 'etcher-electron')
+ 'etcher-electron'
+ 'etcher-electron.desktop')
sha256sums=('a6d08e8e4cf37c233e47317967e29e637e3d1ed72861ae5b239828ffbf312921'
- '70b2eb283cbf03a03232ceefeaa0be2dffd6253ab6a9cd1834dee674ee1e3ab7')
+ 'a64f79fe894c4828b515844703b1795448a4818a654f5d42d4f567f4d80998d1'
+ '89291532fb6e6c5555b43d61c9ba3df103bca0eace040483884b86fd30dca3e4')
prepare() {
cd "$pkgname-$pkgver"
@@ -47,6 +49,13 @@ package() {
cp -a node_modules/ "$_appdir"
install -Dm755 "$srcdir"/etcher-electron "$pkgdir"/usr/bin/etcher-electron
+ install -Dm644 "$srcdir"/etcher-electron.desktop \
+ "$pkgdir"/usr/share/applications/etcher-electron.desktop
+
+ for size in 16x16 32x32 48x48 128x128 256x256 512x512; do
+ install -Dm644 assets/iconset/$size.png \
+ "$pkgdir"/usr/share/icons/hicolor/$size/apps/etcher-electron.png
+ done
}
# vim:set ts=2 sw=2 et: