summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0f102325bab3..bac89a6b4bd0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,16 @@
pkgname=banner-viewer
pkgver=0.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="View and edit GNOME Software banners"
-arch=('any')
-url="https://gitlab.gnome.org/World/design/$pkgname"
+arch=('x86_64')
+url="https://gitlab.gnome.org/World/design/banner-viewer"
license=('GPL')
depends=('gtk3' 'glib2' 'gdk-pixbuf2' 'libhandy' 'gtksourceview3')
makedepends=('git' 'meson' 'rust')
-source=("https://gitlab.gnome.org/World/design/$pkgname/-/archive/$pkgver/$pkgname-$pkgver.tar.gz")
-sha256sums=('SKIP') #autofill using updpkgsums
+checkdepends=('appstream-glib')
+source=("$url/-/archive/$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('e5b3a9a7a38d95a68e27116dd1d039697a738b5008eff4493ecac3ad26d686ab')
build() {
arch-meson "$pkgname-$pkgver" build