summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 19 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b415d58521f8..bd5805de8b04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,26 @@
# Maintainer: Hans-Nikolai Viessmann <hans AT viess.mn>
-pkgname='barvinok'
-pkgver=0.41.4
+pkgname=barvinok
+pkgver=0.41.7
pkgrel=1
-pkgdesc='A library for counting the number of integer points in parametric and non-parametric polytopes'
+pkgdesc='A library for counting the number of integer points in (non-)parametric polytopes'
arch=('x86_64')
-url='http://barvinok.gforge.inria.fr/'
+url='https://repo.or.cz/barvinok.git'
license=('GPL')
-depends=('ntl' 'isl>0.19' 'polylib-gmp')
-source=("http://barvinok.gforge.inria.fr/$pkgname-$pkgver.tar.xz")
-md5sums=('13a3c73e5fcebc0762dc40a763db643f')
+depends=('ntl' 'libisl>0.19' 'polylib-gmp')
+makedepends=('git')
+source=("git+https://repo.or.cz/barvinok.git#tag=$pkgname-$pkgver")
+sha256sums=('SKIP')
+
+prepare () {
+ cd "$srcdir/$pkgname"
+
+ # setup the repo
+ ./get_submodules.sh
+ ./autogen.sh
+}
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
# NTL 11 now uses pthread functions, so we need to have it link to libpthread.
./configure --prefix=/usr --enable-shared-barvinok --with-isl=system --with-polylib=system LIBS="-lpthread"
@@ -19,11 +28,11 @@ build() {
}
check() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
make check
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
make DESTDIR="$pkgdir" install
}