summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 75ceecb9d768..a5639b200b7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=beautyline
pkgver=20240421
_commit=2c1dac627be2bfc3f8047df5697fba466564275f
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc="Outlined icons designed to have unified look and comprehensive coverage with the Candy icon pack (best suited to use with Sweet theme)"
arch=('any')
@@ -15,8 +15,16 @@ source=("git+${url}.git#commit=${_commit}")
sha256sums=('38e869e4e9f69c75de9845c7bcac81c8570f7f2b57899b08ae4298169ca67686')
package() {
+ _move=(actions apps devices index.theme mimetypes places preferences)
+
install -d "${pkgdir}/usr/share/icons/BeautyLine"
- cp -r "${pkgname}/." "${pkgdir}/usr/share/icons/BeautyLine"
+
+ for i in "${_move[@]}"; do
+ cp -r "${srcdir}/${pkgname}/${i}" "${pkgdir}/usr/share/icons/BeautyLine"
+ done
+
find "${pkgdir}/usr" -type f -exec chmod 644 {} \;
find "${pkgdir}/usr" -type d -exec chmod 755 {} \;
+
+ install -Dm644 "${srcdir}/${pkgname}/COPYING" "${pkgdir}/usr/share/licenses/beautyLine/LICENSE"
}