summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 36559ea48482..e2ccd3483505 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Weiman <mark.weiman@markzz.com>
pkgname=bgpstream
-pkgver=2.1.0
+pkgver=2.2.0
pkgrel=1
pkgdesc="An open-source software framework for live and historical BGP data analysis, supporting scientific research, operational monitoring, and post-event analysis"
arch=('x86_64')
@@ -11,10 +11,14 @@ depends=("libwandio>=1.0.3" "librdkafka")
makedepends=('sqlite3' 'git')
optdepends=("sqlite3: sqlite data interface")
source=("https://github.com/CAIDA/libbgpstream/releases/download/v${pkgver}/libbgpstream-${pkgver}.tar.gz")
-md5sums=('19fdcc3514fbd639a2ea5ea0b154a6f4')
+md5sums=('37fd05876cb746403a6a4e6252d5435c')
build() {
cd "${srcdir}/libbgpstream-${pkgver}"
+
+ # fix from #227 on GitHub
+ sed -i '13436 i #define _GNU_SOURCE' configure
+
./configure --prefix=/usr --with-sqlite
make
}