summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 18 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b91c437706f5..b393da55a829 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,35 @@
+# Maintainer: Christian Kugler <syphdias+git@gmail.com>
+# Contributor: Moritz Kaspar Rudert (mortzu)
+# Contributor: Christian Hesse <mail@eworm.de>
+
pkgname=blink1
-pkgver=2.1.0
+pkgver=2.3.0
+_tag=597db6b6a4954dbe9ff17a58b9bf6030bd6aaa89
pkgrel=1
pkgdesc='software for blink(1) USB RGB LED'
arch=('i686' 'x86_64')
url='https://github.com/todbot/blink1-tool/'
license=('GPL')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/todbot/blink1-tool/archive/v${pkgver}.tar.gz")
-source=("git+https://github.com/todbot/blink1-tool.git#tag=v${pkgver}")
-sha256sums=('SKIP')
+makedepends=('git')
+conflicts=('blink1-git')
+source=("git+https://github.com/todbot/blink1-tool.git#tag=${_tag}"
+ 'git+https://github.com/libusb/hidapi.git')
+sha256sums=('SKIP'
+ 'SKIP')
prepare() {
cd "${srcdir}/${pkgname}-tool"
git submodule init
- git submodule update
+
+ git config submodule.hidapi.url "${srcdir}/hidapi"
+
+ git -c protocol.file.allow=always submodule update
}
build() {
cd "${srcdir}/${pkgname}-tool"
+ # remove no-format, since it conflicts with format-security
+ sed -i 's/-Wno-format //' Makefile
make
}