summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cdd603a100f1..ef8ef45479d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=bloodhound
_pkgname=BloodHound
-pkgver=4.2.0
+pkgver=4.3.1
pkgrel=1
pkgdesc="Use graph theory to reveal the hidden and often unintended relationships within an Active Directory"
arch=('x86_64' 'aarch64' 'armv7h')
@@ -11,13 +11,13 @@ license=('GPL3')
depends=('neo4j-community' 'java-runtime>=11')
makedepends=('electron' 'npm' 'python-sphinx' 'python-sphinx_rtd_theme')
optdepends=('python-bloodhound: Python injest tool that runs on natively on Linux')
-source=("https://github.com/BloodHoundAD/BloodHound/archive/${pkgver}.tar.gz"
+source=("https://github.com/BloodHoundAD/BloodHound/archive/refs/tags/v${pkgver}.tar.gz"
"bloodhound.desktop")
-sha256sums=('9e15fb8451d7bd0e537c2d815cdfea7a0553945b6893b4c83ea5aba3e9c72e2a'
+sha256sums=('a0c98140059b25dc1cb1e31f7a809d62b855b5947ee39bbc77c0867819d2d993'
'8a64de7e9fc4857fadd890cc8966a641a896077eb2c869a7eb0987074dcd02c2')
-
build() {
cd "${_pkgname}-${pkgver}"
+ export NODE_OPTIONS=--openssl-legacy-provider
HOME="$srcdir/.electron-gyp" npm install
#HOME="$srcdir/.electron-gyp" npm run linuxbuild
HOME="$srcdir/.electron-gyp" npm run build:linux