summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 5 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 60d7bd1bf679..29d54c46d732 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: Phi11ipus <phi11ipus AT bensherman DOT io>
+# Maintainer: Benjamin Sherman <benjamin AT bensherman DOT io>
# Modified from PKGBUILD in official repositories
pkgname=bochs-sdl
-pkgver=2.6.11
-pkgrel=4
+pkgver=2.7
+pkgrel=1
pkgdesc="A portable x86 PC emulation software package, including GUI debugger, with sdl support"
arch=('x86_64')
url="http://bochs.sourceforge.net/"
@@ -11,17 +11,13 @@ license=('LGPL')
depends=('gcc-libs' 'libxrandr' 'libxpm' 'gtk2')
conflicts=('bochs')
provides=('bochs')
-source=("https://downloads.sourceforge.net/sourceforge/bochs/bochs-$pkgver.tar.gz"
- "fix-build.patch")
-md5sums=('61dbf6d5c0384712e1f3e51e88381b4c'
- '0ae4954b32d49ac3c7a2431ea7935d1c')
+source=("https://downloads.sourceforge.net/sourceforge/bochs/bochs-$pkgver.tar.gz")
+md5sums=('d77a43c21cfd8aa013eb2eaa35644f80')
prepare() {
cd "$srcdir/bochs-$pkgver"
# 4.X kernel is basically 3.20
sed -i 's/2\.6\*|3\.\*)/2.6*|3.*|4.*)/' configure*
-
- patch -p1 < ../fix-build.patch # https://sourceforge.net/p/bochs/bugs/1411/
}
build() {